Getting the 0.44pre1 (Or latest git) SDK running on Windows

General help specific to the Windows platform.
Post Reply
jerome
Site Admin
Posts: 603
Joined: Sat Jan 16, 2010 11:16 pm

Getting the 0.44pre1 (Or latest git) SDK running on Windows

Post by jerome »

... in 5 easy steps:

- Install 0.43 with convenient installer for MinGW in default location (Program Files/Ecere SDK)
- Go in Program files/Ecere SDK/mingw/bin and rename (or copy) make.exe to 'mingw32-make.exe'

- Unpack the 0.44pre1 tar ball
or
- git clone git://github.com/ecere/sdk.git

- Open command prompt, if on Vista or 7 make sure you open it as administrator (Start, 'cmd', right click terminal icon, Run as administrator) go to directory, hit 'mingw32-make'
- Do 'mingw32-make install', this will overwrite the 0.43 binaries with the new binaries
santy
Posts: 4
Joined: Fri Mar 19, 2010 10:02 am

Re: Getting the 0.44pre1 SDK running on Windows

Post by santy »

Hi

I made SDK using Mingw 4.4.1.
For test I built static library SDK. Simple console program has very big size, near 3M. Very big.
May be have you ideas for changing size?

Thanks
jerome
Site Admin
Posts: 603
Joined: Sat Jan 16, 2010 11:16 pm

Re: Getting the 0.44pre1 SDK running on Windows

Post by jerome »

santy,

The Ecere.epj project has various configurations which include various parts of the library.
Right now you have the whole shabang, including the 3D stuff (a Direct3D 8, Direct3D 9, OpenGL engine!), drivers for DirectDraw, GDI, Console, printing...., builtin support for jpeg, gif, png, true type fonts, zlib compression, complex script shaping, and all that. That's why your simple console app is 2 mb.

If you only want to use eC without the Ecere GUI toolkit and library, you can link with ecereCOM instead of ecere. If you want just the basic GUI stuff, you can try the 'Vanilla' configuration. And various preprocessor definitions controls what gets included in the library when you build it.

You can get a simple GUI app under 800k.
Compare this with something that uses the .NET framework which takes up 100 mb.
:D
santy
Posts: 4
Joined: Fri Mar 19, 2010 10:02 am

Re: Getting the 0.44pre1 SDK running on Windows

Post by santy »

no .NET :)

Thanks jerome. I found this configuration and test it.

For testing I took boostraps libraries and built simple program. size is near 250K (don't pack) :) Good size.


Thank you.
Lou
Posts: 1
Joined: Fri Apr 02, 2010 2:05 am

Re: Getting the 0.44pre1 SDK running on Windows

Post by Lou »

Hi,
I followed the steps that outlined above (first post) but I get the following errors:

bootstrap\dataTypes.c:2005: error: conflicting types for '__ecereNameSpace__ecere__com__eSystem_Delete'
bootstrap\dataTypes.c:389: error: previous implicit declaration of '__ecereNameSpace__ecere__com__eSystem_Delete' was here
mingw32-make[3]: *** [obj/bootstrap/dataTypes.o] Error 1
mingw32-make[2]: *** [ecere] Error 2
mingw32-make[1]: *** [bootstrap] Error 2
mingw32-make: *** [bootstrap] Error 2

What could possibly have gone wrong?
jerome
Site Admin
Posts: 603
Joined: Sat Jan 16, 2010 11:16 pm

Re: Getting the 0.44pre1 SDK running on Windows

Post by jerome »

Hi Lou,

If you do at that same command prompt 'gcc --version', what do you get?
The version that the Ecere SDK 0.43 installer installs should read

'gcc (GCC) 4.3.0 20080305 (alpha-testing) mingw-20080502'

I suspect you already had a MinGW installation that has precedence in the path and that is why you get these errors... Let me know!

Cheers,

Jerome
azrak
Posts: 2
Joined: Sat Apr 24, 2010 7:05 pm

Re: Getting the 0.44pre1 SDK running on Windows

Post by azrak »

hi jerome..that what i get :

Packed 1 file.
Building 2nd stage compiler
Building 2nd stage libec...
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:1403:28: warning: incompatible expression yy_ec[((unsi
gned int)(unsigned char)*yy_cp)] (int); expected byte
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:1413:13: warning: incompatible expression yy_meta[(uns
igned int)yy_c] (int); expected byte
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:2566:27: warning: incompatible expression (*yy_cp ? yy
_ec[((unsigned int)(unsigned char)*yy_cp)] : (unsigned char)1) (int); expected b
yte
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:2576:12: warning: incompatible expression yy_meta[(uns
igned int)yy_c] (int); expected byte
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:2611:11: warning: incompatible expression yy_meta[(uns
igned int)yy_c] (int); expected byte
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:426:26: warning: incompatible expression c (int); expe
cted char
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\src\lexer.ec:434:29: warning: incompatible expression c (int); expe
cted char
C:\Documents and Settings\yo\Escritorio\ecere-sdk-0.44pre1\ecere-sdk-0.44pre1\co
mpiler\libec\obj\release\ec.main.ec:525:1: warning: Redefinition of sourceFileSt
ack (defining as char[10][MAX_LOCATION], already defined as char[MAX_INCLUDE_DEP
TH][MAX_LOCATION])
Building 2nd stage ecp...
Building 2nd stage ecc...
Building 2nd stage ecs...
Building eC Core Runtime...
Building IDE...
Building epj2make...
Building Documentor...
Building EDA...
The Ecere SDK is fully built.

but in the end all work fine.
sanyaade
Posts: 11
Joined: Thu Jul 22, 2010 6:13 pm

Re: Getting the 0.44pre1 SDK running on Windows

Post by sanyaade »

Hi Jerome,

I am having problems building the Ecere SDk on Windows. I have built the 0.43 before on windows but I cannot remember the steps (long long time ago.). I have followed the instructions stated above but I got the following error:
The system cannot find the path specified
mingw32-make: *** [bootstrap] Error 1

It stops at those two lines. Is there a special folder layout that I must follow or what do I need to do.
I will continue to play with but I need to get it build and the 0.44 binary will not run due to make error despite global setting being well set.

God blesses!!!

Best regards,
Sanyaade
redj
Posts: 105
Joined: Sun Jan 17, 2010 10:03 am

Re: Getting the 0.44pre1 SDK running on Windows

Post by redj »

Hi Sanyaade,

See the New Ecere SDK pre-release September 5, 2010 topic for latest files.

I've updated the winbin.zip file just now. Although I don't think this is related to your current problem, the IDE in the previous windows binaries file would have caused problems when compiling projects.

Also, did you download the new ecere-sdk-0.44pre-2010-09-06.tar.bz2 tarball?

Concerning your current issue:
sanyaade wrote:I have followed the instructions stated above but I got the following error:
The system cannot find the path specified
mingw32-make: *** [bootstrap] Error 1
That's the only output you get for the make command?
Yo do have Ecere SDK 0.43 or Mingw32 installed on this machine, right?
(check gcc --version)

-redj
sanyaade
Posts: 11
Joined: Thu Jul 22, 2010 6:13 pm

Re: Getting the 0.44pre1 SDK running on Windows

Post by sanyaade »

Hi redj
redj wrote: That's the only output you get for the make command?
Yo do have Ecere SDK 0.43 or Mingw32 installed on this machine, right?
(check gcc --version)
-redj
Thank you very much, the problems has been solved. It was due to corrupted files. I re-download the pre-0.44 bzip tarball again and compiled it smoothly. I was able to run the examples as well.

Many thanks!
God blesses!!!

Best regards,
Sanyaade
Post Reply