Ecere SDK/eC Forums • View topic - EDE explorer failed to build since latest SDK




Ecere SDK/eC Forums

Ecere Developers Community

EDE explorer failed to build since latest SDK

General help with the Ecere Cross Platform GUI toolkit: Window, common controls, events, etc.
Help with the 2D Graphics library: Surface, Display, Bitmap, Font and others.

EDE explorer failed to build since latest SDK

Postby samsam598 » Sun Oct 16, 2011 8:30 pm

Hello,

All the EDE lib and samples can be built without a single problem as of before the lastest ecere SDK(eda/edb: Proper fix for ecere.com/mantis/view.php?id=646 (fb5b0907e281e269dcb01ab1a14fe5b00f79639a introduced a bug).Just noticed that the lib and the FileSystemBox can be built as well in the lastes ecere ,but the example Explorer can not pass build any more.

I don't know what change(s) in SDK caused this issue.Could you please help?Thanks.
Code: Select all

ExplorerWindow.c
   src\ExplorerWindow.ec:292: error: '__ecereClass_FlipStacker' undeclared (first use in this function)
   src\ExplorerWindow.ec:292: error: (Each undeclared identifier is reported only once
   src\ExplorerWindow.ec:292: error: for each function it appears in.)             
samsam598
 
Posts: 208
Joined: Thu Apr 14, 2011 9:44 pm

Re: EDE explorer failed to build since latest SDK

Postby jerome » Sun Oct 16, 2011 9:53 pm

Hi Sam,

I had to revert the FlipStacker code for stability reasons in the IDE.

The EDE/Explorer projects are very experimental in nature, so please don't expect them to build :)

We will look into fixing this soon, though.

Thanks!

Regards,

Jerome
jerome
Site Admin
 
Posts: 623
Joined: Sat Jan 16, 2010 11:16 pm


Return to GUI Toolkit & 2D Graphics

Who is online

Users browsing this forum: No registered users and 3 guests

cron