Ecere SDK/eC Forums • View topic - Troubles with Clock sample

Ecere SDK/eC Forums

Ecere Developers Community

Troubles with Clock sample

Help understanding and fixing compiling errors.

Troubles with Clock sample

Postby nickdobrinich » Sun Mar 03, 2013 2:26 am

I have recently rediscovered this old problem on a new Win XP machine.
When trying to compile the clock project I get: Couldn't open obj/debug.win32\clock.sym
And missing sym files with every other app as well.

I've tried all the suggested fixes in this thread.
MS SDK, environment path setting, include and library settings.
I uninstalled the Windows setup version of 0.44 and tried the Portable version 0.44.a with the same results.
I've searched the Windows Event log and found nothing.
Being new to Ecere, I'm not sure where to find logs that can point me in the right direction.

My confusion is also with the dependencies on Windows SDK.
I thought the widgets in Ecere were self contained.

Of note: the Puppy Linux side of this same machine works perfectly.
Which is one reason I stay off the Windows side as much as possible.
But several of my apps are cross platform and will ultimately run on Windows.
Posts: 10
Joined: Thu Feb 14, 2013 9:24 am

Re: Troubles with Clock sample

Postby jerome » Sun Mar 03, 2013 10:30 am

Hi Nick,

I think this is different problem than the topic where you initially posted.
Also that topic had turned into something completely different (crashes), so to avoid the confusion I moved it here.

First of all, this error message:

"Couldn't open obj/debug.win32\clock.sym"

Means that somehow the eC precompiler (ecp) failed to do his job.
There could be various reasons why, and a common one is because the C preprocessor itself failed, often due to missing header files. That was the cause in the other topic, and why it had to be pointed to the Windows SDK.

The Ecere widgets *are* self-contained. But that other topic was trying to build the platform specific implementations for the Ecere Audio library.

However, here you're trying to build the Clock sample, which from what I can see, does not include any header files at all, at least in the version that I have. How about your version? Do you see any #include in it? Is it possible that you could have modified the sample from its original form?

It is possible that the SDK is not installed properly. It's important to set up a compiler with the paths for both the Ecere compiler executables as well as to MinGW which provides GCC. When you install the 0.44 setup, it should automatically do all these things.

Do verify that in File/Global Settings/Compiler, select Default compiler, and that you have (assuming you are on a 64 bit machine, and this is the 32 bit executables, and MinGW has been installed into C:\Program Files (x86)\ECERE SDK\mingw):

Library Files
C:\Program Files (x86)\ECERE SDK\bin

Executables Files
C:\Program Files (x86)\ECERE SDK\bin
C:\Program Files (x86)\ECERE SDK\mingw\bin

Also make sure all executables are in C:\Program Files (x86)\ECERE SDK\bin, specifically ecp.exe which is the precompiler that is failing here.

Please come back with more information if you are still having issues so we can figure out what the problem is.


Site Admin
Posts: 623
Joined: Sat Jan 16, 2010 11:16 pm

[SOLVED] Re: Troubles with Clock sample

Postby nickdobrinich » Wed Mar 06, 2013 2:26 am

Well as it turns out, I had an old Unix shell suite I had loaded several years ago on the windows side.
Long forgotten once I installed Cygwin, it was hanging out hidden at the far end of my path.
So now Ecere runs everything cross platform, just as advertised.
Your Ecere Global settings above are correct.
Note that it compiles at about 1/2 the speed of the Linux side on the same hardware.
And since it's windows, it is always and will remain the supreme PITA I remember.
Since I rarely go over to the dark side, I had 127 updates to post, then some more, and then more.
Plus Genuine Disadvantage.
Plus some Active Desktop stupidity.
Plus Java. Plus AV updates.
Serves me right for ever booting into it.

Sorry for the trouble call.
You are the fastest and most complete tech supporter on the planet.
I certainly appreciate your pointing the way for a noob.
Posts: 10
Joined: Thu Feb 14, 2013 9:24 am

Re: Troubles with Clock sample

Postby jerome » Wed Mar 06, 2013 4:12 am

You're most welcome Nick :)

You might be interested in the cross-compiling features of Ecere :)

sudo apt-get install mingw32 # For the classic 32 bit MinGW tool chain
sudo apt-get install mingw-w64 # For MinGW-w64 which supports both 32 and 64 bit

You can build (and test if you want, with Wine!) Ecere applications for Windows right from the comfort of your Linux OS.

I've noticed Windows or MinGW was much slower at running GCC than on Linux.
I don't know if it is because the GCC toolchain is compiled without optimizations or what...

Another thing you can do is in File/Global Settings/Compilers/Options, set Number of Parallel build jobs to as many cores & hyper threads as you have on your CPU (e.g. on a Quad Core or i7 with Hyper-Threading set this to 8). This gets things going much faster if you have a Quad Core or i7.

Also, MinGW-w64 might be somewhat faster than the classic MinGW, so you could try configuring it as your compiler instead.

I'm in the middle of preparing the new Ecere release with 64 bit support right now!
Stay alert for a new update!

(You can always stay up to date with the bleeding-edge by cloning our repository on Github as well)

Cheers :D ,

Site Admin
Posts: 623
Joined: Sat Jan 16, 2010 11:16 pm

Return to Compiler Errors

Who is online

Users browsing this forum: No registered users and 0 guests