Page 1 of 1

using clang with ecere-ide as the default compiler

PostPosted: Wed Feb 20, 2019 10:14 am
by alepi
Hi,

I am quite new to ecere so please forgive me if I ask silly questions while I am learning.

My machine uses linux with clang only ( there is no gcc at all, gcc is a symbolic link to clang ). So I need to be able to use clang with ecere-ide.

I compiled all of ecere from github myself with clang, so I know for a fact that ec can drive clang.

I have written the hello world example with the ecere-ide. When I compile it, it says:

clang-8: error: unknown argument: '-fno-diagnostics-show-caret'

I assume that '-fno-diagnostics-show-caret' is a gcc only flag that is used by ecere-ide when compiling.

How can I fix that? Is there any particular setting to remove the offending compiler flag?

I tried editing .ecereIDE/compilerConfigs/Default.econ so that the default compiler is set to clang but that compiler flag has not been removed ( unsurprisingly ).

Thanks :-)